(1) Ikatlah ilmu dengan menuliskannya...

Install XAMPP (LAMPP) di mesin CentOS x86_64 (64 bit)

Seperti yang kita ketahui bersama kalau xampp for linux (LAMPP) untuk saat ini secara default tidak bisa diinstall di mesin 64 bit. Lalu gimana caranya kalau kita terpaksa haru menggunakan xampp for linux untuk paket apache, php, mysql dan phpmyadmin di server CentOS 64bit kita?

Caranya gampang, pertama install dulu library 32 bit di CentOS 64 bit kita :

yum install glibc.i686

Kedua, beri komentar pada baris berikut pada file /opt/lampp/lampp

# XAMPP is currently 32 bit only
case `uname -m` in
       *_64)
       if /opt/lampp/bin/php -v > /dev/null 2>&1
       then
               :
       else
               $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
               $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
               exit
       fi
       ;;
esac

menjadi :

# XAMPP is currently 32 bit only
#case `uname -m` in
#       *_64)
#       if /opt/lampp/bin/php -v > /dev/null 2>&1
#       then
#               :
#       else
#               $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
#               $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
#               exit
#       fi
#       ;;
#esac

Selesai, tinggal jalanin lagi lampp dengan perintah :

/opt/lampp/lampp start

Starting XAMPP 1.7.7...
LAMPP: Starting Apache...
LAMPP: Starting MySQL...
LAMPP started.

Seharusnya lampp (xampp for linux) bisa berjalan dengan normal.

Sekian semoga membantu :)

<< Go back to the previous page